Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-10279

Global users are not suggested when trying to send them a message from a subwiki

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      1. Login with Admin
      2. Create a new global user named "globalUser"
      3. Create a new subwiki: select "Only global users are available in the wiki" as the User Scope and add globalUser as a member
      4. You'll get a merge conflict for XWiki.XWikiAllGroup: keep the current version of the document and click Continue
      5. Edit Main.WebHome inline and add the Message Sender gadget
      6. Select User from the drop-down list and begin typing "globalUser"

      The search suggest will display "User not found".

      I have tested the same scenarios on the main wiki and a subwiki with local users and I couldn't reproduce this issue.

      Re XWIKI-6668: Also if you create a new group in the subwiki, add globalUser as a member and then send a message to that group, globalUser won't receive the message.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gdelhumeau Guillaume Delhumeau
                Reporter:
                msmeria Manuel Smeria
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: