Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-12581

Sublink in administration redirected to main admin page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 7.2-rc-1
    • Fix Version/s: 7.3-milestone-1
    • Component/s: Administration
    • Labels:
    • Environment:
      XWiki 7.2 RC1, Debian + MySQL + Tomcat7, manuall installation (not Debian package).
      The xwiki is subwiki
      Logged as xwiki admin (not as owner / admin of parent xwiki).
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Links belonging to images presenting administration groups (e.g. in XWiki Administration > Users & Groups) don't lead to their pages, but a user is redirected to a main Administration page.

      See attached image: If I click on Groups image, I will go not to Administration: Groups, but to the main Administration page.

      Links in the left column works fine.

      The difference is "&" vs. "&":
      Working URL: http://myweb/xwiki/bin/admin/XWiki/XWikiPreferences?editor=globaladmin&section=Groups
      Not working URL: http://myweb/xwiki/bin/admin/XWiki/XWikiPreferences?editor=globaladmin&section=Groups

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                jan_slegr Jan Šlegr
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: