XWiki Platform
  1. XWiki Platform
  2. XWIKI-13740

The document tree is not loading on a sub wiki dashboard

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 8.3-milestone-2, 7.4.5
    • Fix Version/s: 8.3, 7.4.6
    • Component/s: Wiki
    • Labels:
    • Development Priority:
      High
    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Similar issues:

      Description

      You can reproduce very easily by creating a new sub wiki (if you don't have one already) and accessing the WikiManager.Dashboard page.

        Issue Links

          Activity

          Marius Dumitru Florea added a comment -

          Regression caused by XWIKI-12909. The fix is quite simple: edit the WikiManager.Dashboard page using the object editor and delete the (deprecated) EditModeClass object. This object prevents the sheet specified on the request from being applied. Starting with XWIKI-12909 the document tree is using the sheet request parameter when fetching the child nodes in order to preserve the context document (the alternative would have been to pass the context document as a request parameter).


            People

            • Assignee:
              Marius Dumitru Florea
              Reporter:
              Marius Dumitru Florea
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: