Details

    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Pull Request Status:
      Pull Request accepted
    • Similar issues:

      Description

      If you grep the code for IE6, you'll see that there are a lot of pages that include hacks for IE6. XWiki should not support or encourage the use of IE6 because Microsoft stopped fixing its security holes in April 2014.[1] Anyone who is still using IE6 is at risk of security breach and data theft. Meanwhile, up-to-date browsers are being slowed down by having to download and process the IE6 code.

      Please speed up XWiki by removing support for Internet Explorer 6 and under. At the same time, support can also be removed for Firefox 44 and under, as those versions are not receiving security updates anymore either.[2]

      This request is consistent with, and more conservative than, XWiki's stated policy of no support for Internet Explorer 9 and under.[3]

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                alex.henrie Alex Henrie
                Reporter:
                alex.henrie Alex Henrie
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: