Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14365

CAPTCHA Does Not Appear on Registration Form

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Inactive
    • Affects Version/s: 8.4.5
    • Fix Version/s: None
    • Component/s: CAPTCHA
    • Labels:
      None
    • Environment:
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Dear All,
      I have configured a sub-wiki to allow user registration, with verification by the sub-wiki owner. Unfortunately, the CAPTCHA that I have enabled, does not appear, and the registration fails with this log entry:

      2017-06-17 13:19:14,012 [https://www.synalinq.com/xwiki/wiki/testwiki/register/XWiki/XWikiRegister?xredirect=%2Fxwiki%2Fwiki%2Ftestwiki%2Flogin%2FXWiki%2FXWikiLogin%3Fsrid%3Dh9bbzsjM%26xredirect%3D%252Fxwiki%252Fwiki%252Ftestwiki%252Fview%252FMain%252F%253Fsrid%253Dh9bbzsjM] WARN  c.x.x.w.RegisterAction         - Cannot verify captcha answer: Invalid ID, could not validate unexisting or already validated captcha 
      

      The above error message appears to be a logical consequence of the fact that I could not complete the CAPTCHA, as it did not appear .
      I am sure I am missing something? Thanks a lot for your help!
      Chris

        Attachments

          Activity

            People

            • Assignee:
              surli Simon Urli
              Reporter:
              chlarsen Christoph Larsen
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: