Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14726

The admin user created with the Distribution Wizard is not added in XWikiAdminGroup

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 8.0
    • Fix Version/s: None
    • Component/s: Distribution
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Follow the steps inside the Distribution Wizard and create a new admin user, install the flavor, etc.

      The new user will be added in the XWikiAllGroup, but not in the XWikiAdminGroup.

      I don't know if this has additional consequences, since the user has the correct permissions since he is the owner of the wiki (XWiki.XWikiServerXwiki).

      The main problem is that there is an inconsistency with the Standard 'Admin' user and might produce some confusion for the users.

        Attachments

        1. administrationGroups_Standard_Expected.png
          administrationGroups_Standard_Expected.png
          147 kB
        2. administrationGroups.png
          administrationGroups.png
          147 kB
        3. pagesReport.png
          pagesReport.png
          162 kB
        4. wikis.png
          wikis.png
          439 kB
        5. xwikiDescriptor.png
          xwikiDescriptor.png
          163 kB

          Issue Links

            Activity

              People

              Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              evalica Ecaterina Moraru (Valica)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: