Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14781

All Page notifications are cleared from the list when enabling Blog notifications and vice versa

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 9.8.1
    • Fix Version/s: 9.9, 9.10-rc-1
    • Component/s: Notifications
    • Labels:
      None
    • Environment:
      IE 11
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Preconditions: Have the blog app installed
      Steps to reproduce:

      1. Log in as a user and enable the Pages Notification (email not needed)
      2. Log in as another user/admin
      3. Create / update / delete pages
      4. Log in with the first user again
      5. Observe the Notifications list
      6. Click on Notifications Settings
      7. Enable the Blog notifications
      8. Refresh the page

      Actual results: After enabling the blog notifications and refreshing the page all the previous notifications disappear.
      The same thing happens when enabling the Blog notifications first and then the Page notifications.

        Attachments

        1. Step1.jpg
          Step1.jpg
          109 kB
        2. Step2.jpg
          Step2.jpg
          52 kB
        3. Step3.jpg
          Step3.jpg
          151 kB

          Issue Links

            Activity

              People

              • Assignee:
                gdelhumeau Guillaume Delhumeau
                Reporter:
                ganechitoaei Gabriela Anechitoaei
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: