Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14782

"Failed to save your settings" when enabling the toggles too fast

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 9.8.1
    • Fix Version/s: 9.11.2, 10.1-rc-1
    • Component/s: Notifications
    • Labels:
      None
    • Environment:
      IE 11, Chrome 61, Firefox 57, local 9.8.1 instance with MySQL
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Preconditions: Have the Blog app installed.
      Steps to reproduce:

      1. Log in as Admin or simple user
      2. Click on the Bell
      3. Click on Notifications Settings
      4. Enable The Blog and Pages notifications - Without waiting for the "Your settings are being saved" message to disappear

      Expected results: Notifications messages appear to let the user know that the changes are in process of being saved.

      Actual results: When the user doesn't wait for the confirmations message of "Saved!" to appear and he keeps on clicking he gets the "Failed to save your settings" message. This is an issue and should be changed. Either make the other toggles enabled till the first one is saved or make more messages of saving is in progress, so the "Failed to save your settings" doesn't appear.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gdelhumeau Guillaume Delhumeau
                Reporter:
                ganechitoaei Gabriela Anechitoaei
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: