Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14846

A useless "update" event is always present in the details of a notification about comments

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 9.10-rc-1
    • Fix Version/s: 9.10, 9.11-rc-1
    • Component/s: Notifications
    • Labels:
      None
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      • With UserA, enable all notifications
      • With UserB, add a comment on "Main.WebHome"

      With UserA, you get this kind of notification:

      We have already discussed of that in XWIKI-14816.

      What happens is that technically, when you add a comment, you also save the page where you have added a comment (since adding a comment is actually adding an xobject on the page).

      It means that we generate 2 events: 1 "addComment" and 1 "update".

      I have written a complex algorithm to group events (by creating "composite events"), and this algorithm already handles this use case. It means that we group "addComment" and "update" in the same composite event.

      However, when you see the details of such composite events, you see the 2 lines, because Vincent Massol wanted to be able to see ALL events when you unfold a composite event.

      In my opinion, displaying this "update" here is a non-sense. There is absolutely no need for knowing that adding a comment is actually an update. The diff generated for both events are exactly the same (since they concern the same document revision). So there is no lose of information if we remove the "update" line. The current situation only leads to UI complexity that we try to avoid in XWiki.

      That's why, in this particular case, I decide to hide the "update" events from the details section (the unfolded one) when they are actually duplicating a more high-level event.

      Of course, it does not mean to hide "update" events everywhere.

        Attachments

          Activity

            People

            • Assignee:
              gdelhumeau Guillaume Delhumeau
              Reporter:
              gdelhumeau Guillaume Delhumeau
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: