Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15196

SMTP settings used for each new wiki not inherited from xwiki.properties

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 9.10.1
    • Fix Version/s: 11.8-rc-1
    • Component/s: Mail
    • Labels:
    • Environment:
      docker centos
    • Tests:
      Unit
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      If you set the SMTP parameters in the file "xwiki.properties" according to this document : http://extensions.xwiki.org/xwiki/bin/view/Extension/Mail%20Sender%20API#HConfiguration

      the SMTP parameters used should the one of the "xwiki.properties" file if the others are empty.
      It's working only for the default wiki.
      For the other wiki the parameters are not herited from "xwiki.properties".

      When you want to send a link by mail the interface should also check if the current wiki is using global users of not. Because the dialog are proposing global list of users only for main wiki.

       

      Regards.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                Camille_D Camille Desmots
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: