Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15263

Warn the user if he's using Java 9+ since we currently don't support it officially and there are problems remaining

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 10.3
    • Fix Version/s: 10.4-rc-1
    • Component/s: Jetty resources (Tool)
    • Labels:
    • Environment:
      Java 9
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Users have reported being surprised to see if not working. Ofc we document it but it would be even nicer to display a warning message so that they know about it when they start xwiki standalone (which is supposed to be for anyone to use, including newbies to java and currently when someone installs java they get java 10 which is displaying some ugly stack trace).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                vmassol Vincent Massol
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: