Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15462

Messages sent to multiple users are received only by the first added user

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1
    • Fix Version/s: 10.7-rc-1
    • Component/s: Message Stream
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, IE11, using a local instance of XWiki 10.6.1 on MySQL 5.7
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Login as Admin
      2. Go to Administer Wiki > Other > Message Stream and enable it
      3. Create 2 users (e.g. U1 and U2)
      4. Login with U1, respectively with U2
      5. Go to Notifications > Settings
      6. Set Message Stream toggles to ON for both U1 and U2
      7. Login with Admin
      8. Go to Profile and write a message
      9. Set the message to be visible to 'User'
      10. Add U1, then add U2
      11. Click 'Share'
      12. Login with U1, respectively with U2
      13. Observe the notifications list

      EXPECTED RESULTS

      The message sent by Admin is received both by U1 and U2.

      ACTUAL RESULTS

      Although the message was sent by Admin to both users, it was received only by the first user which was added in the field (U1).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                atallahade Adel Atallah
                Reporter:
                iandriuta Ilie Andriuta
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: