Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15854

Default value of static lists are not selected in object editor

    Details

    • Type: Bug
    • Status: Open
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 10.9
    • Fix Version/s: None
    • Component/s: Old Core
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce

      1. Login as an Administrator
      2. Create an xclass in any page
      3. Add a property of type 'Static List' to this xclass
      4. Set 'Default Value' to 'c'
      5. Set 'Values' to 'a=b|c=d'
      6. In any page, open the object editor and add an instance of the xclass

      Expected result

      The value 'd' is selected in the static list

      Actual result

      The value 'b' is selected

       

      Note that setting the default value to 'e' will actually select 'e' even though it's not in the list of possible values, so my guess is that the default value is actually selected but not displayed as such.

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              atallahade Adel Atallah
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Date of First Response: