Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15888

Missing sub elements under "More Applications"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 10.10-rc-1
    • Fix Version/s: 10.10
    • Component/s: Rendering - Async
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, Firefox 63, using a local instance XWiki 10.10 RC1 on Oracle 11.2
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Login as Admin
      2. Expand the 'More applications' menu from below the Applications panel
      3. Create an user
      4. Login with the user
      5. Expand the 'More applications' menu

      EXPECTED RESULTS

      When logged in as Admin, the 'More applications' menu contains two links: 'Create your own!' and 'Install new applications'. The user can see only 'Create your own!' link.

      ACTUAL RESULTS

      When logged in as Admin, 'Create your own!' link is missing from 'More applications' menu.
      As a regular user, the whole menu 'More applications' is missing (it appears for app. 1 second and disappears after).

      The issue cannot be reproduced on XWiki 10.9.

        Attachments

          Activity

            People

            Assignee:
            tmortagne Thomas Mortagne
            Reporter:
            iandriuta Ilie Andriuta
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: