Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 10.10
    • Fix Version/s: None
    • Component/s: Dependency Upgrades
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      See https://bitbucket.org/birkenfeld/pygments-main/src/f3f550c25fe0caba1cb725dd1994363c003d97f2/CHANGES?at=2.3.1

      - Updated lexers:
      
        * ASM (PR#784)
        * Chapel (PR#735)
        * Clean (PR#621)
        * CSound (PR#684)
        * Elm (PR#744)
        * Fortran (PR#747)
        * GLSL (PR#740)
        * Haskell (PR#745)
        * Hy (PR#754)
        * Igor Pro (PR#764)
        * PowerShell (PR#705)
        * Python (PR#720, #1299, PR#715)
        * SLexer (PR#680)
        * YAML (PR#762, PR#724)
      
      - Fix invalid string escape sequences
      - Fix `FutureWarning` introduced by regex changes in Python 3.7
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                tmortagne Thomas Mortagne
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: