Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-16005

URL of Links in Panels broken when XWiki is installed as default app

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.11.1, 11.0
    • Component/s: None
    • Labels:
    • Environment:
      xwiki 10.11 tomcat postgres on Docker, official image
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      This is a huge issue for xwiki 10.11 stable.

      Steps to reproduce:

      • use docker-compose-postgres.yml of docker xwiki repo
      • Set Image to
        xwiki:10.11-postgres-tomcat
      • Connect, register Admin, install Standard Flavor

      Upon arriving on Main Page, links in Panels are broken, they link to /bin/bin/....

      See screenshots.

      Other links (in page / NavigationTree / Breadcrumbs) seem fine

      This affects at least:

      • Application Panel
      • My Recent Modifications Panel

      The workaround is to set the property "xwiki.webapppath" properly in xwiki.cfg which is mandatory according to the documentation anyway but it was forgotten in the docker image (see XDOCKER-91).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              AutomationX Mario (AutomationX)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: