Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-16788

Only the page content appears in the HTML export

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 11.8-rc-1, 11.8.1
    • Fix Version/s: 11.9
    • Component/s: Old Core - HTML Export
    • Environment:
      Windows 10, XWiki 11.8RC 1 and XWiki 11.8.1 Chrome 77
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      1. Create a page e.g. P1 and add some content
      2. Create a child page P2 (P1/P2)
      3. Create a child page P3 (P1/P2/P3)
      4. Export as HTML page P1 with children
      5. Extract the zip
      6. Open the Index page
      7. Open each page

      Expected results: The exported pages are the same as the original ones.

      Actual results: Only the first page that appears in the list is showing properly. The other 2 pages appear as the content of the page only - the left/right panels are missing, also the top menu, header and footer.

      NOTE: HTML export works fine on 11.7

        Attachments

        1. 3RdPage.jpg
          3RdPage.jpg
          271 kB
        2. FirstPage.jpg
          FirstPage.jpg
          164 kB
        3. HTMLExport.jpg
          HTMLExport.jpg
          9 kB
        4. SecondPage.jpg
          SecondPage.jpg
          322 kB

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                ganechitoaei Gabriela Anechitoaei
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: