Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-17505

Pages missing when using SOLR search engine

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 11.10.4
    • Fix Version/s: None
    • Component/s: Search - Solr
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      When using the default search engine SOLR, some pages are not found. In my case reproduction is easy as I can go to a random page, choose a word and plug it into the SOLR search. It is really likely that the before visited page is not found.

      SOLR itself seems to be working as there are results for certain keywords but not for others.

      Adding everything to the index, reindexing, deleting the index and adding it again and deleting (renaming) the /var/lib/xwiki/data/solr folder are not fixing the issue. The index queue is set to allow 100'000 entries at max, but I have only seen up to 16'500 entires in the queue.

      The catalina.out is free of errors (at default log level). There are some warning about not being able to read a resource "Failed to read resource [font-awesome/4.7.0/css/font-awesome.min.css]", but I don't think it's related to this issue.

      Using the database search everything is found as expected but we cannot use multiple keywords or other advanced search functionalities with this method.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              s.trachsel@voegeli.ch Sven Trachsel
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Date of First Response: