Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-17625

Captcha doesn't appear as mandatory on registration form, no error message appears when clicking register without Captcha

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 12.6
    • Fix Version/s: None
    • Component/s: CAPTCHA
    • Labels:
      None
    • Environment:
      Windows 10, Edge 84
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce:

      1. Access Administer Wiki
      2. Click on Other > CAPTCHA
      3. Select Type > Text
      4. Select one of the Engine
      5. Click on the Save button
      6. Click on Registration
      7. Tick "Require CAPTCHA to register"
      8. Click on the Save button
      9. Log out of the wiki
      10. Click on Drawer > Register
      11. Observe the required fields
      12. Complete the fields but not the CAPTCHA
      13. Click on Register

      Expected results: The Captcha appears as mandatory, if not completed the user can see a message after the Register button is clicked.

      Actual results: The Captcha is not marked as mandatory. Once the user completes the required marked fields and clicks on Register nothing happens - the user isn't created but there is no message to inform the user that the Captcha is mandatory.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ganechitoaei Gabriela Anechitoaei
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: