Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18339

Users avatars are displayed as HTML code on "User Directory" when using LiveData macro

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 13.0, 12.10.4
    • Fix Version/s: 13.1-rc-1, 12.10.5
    • Component/s: Live Data
    • Labels:
      None
    • Environment:
      Windows 10 Pro 64 bit, Chrome 88, Firefox 85, using a Docker instance of XWiki 12.10.4 on PostgreSQL 13, Tomcat
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Go to Drawer > User Index
      2. Use ?useLiveData=true in URL
      3. Observe the Picture column

      EXPECTED RESULTS

      The users' avatars are properly displayed as pictures.

      ACTUAL RESULTS

      Some HTML code is displayed instead, like:

      <img src='http://localhost:8080/bin/download/XWiki/U1/Avatar.jpg?width=120&#38;height=120&#38;keepAspectRatio=true&#38;rev=1.1' alt='User One' title='User One'/>

        Attachments

          Activity

            People

            Assignee:
            mflorea Marius Dumitru Florea
            Reporter:
            iandriuta Ilie Andriuta
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: