Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18405

Attachment related warnings in browser when upgrading to XWiki 13.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 13.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, Edge 89, using a local instance of XWiki 13.1 on MySQL 8, Tomcat 9.0.43
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Create (or unzip) an older instance of XWiki (e.g. 12.6.8)
      2. Close the instance
      3. Go to an instance of 13.1 and copy/cut the
        [...]webapps\xwiki

        folder and replace it (first delete the old one) in the same location on the older (12.6.8) version

      4. Start XWiki and follow DW

      EXPECTED RESULTS

      No warnings/errors are displayed in browser when running Distribution Wizard.

      ACTUAL RESULTS

      On 'Step 2 - Flavor', there are some warnings displayed, related to attachments. The same warnings reproduce when running the DW for a subwiki:

      The issue could not be reproduced when upgrading from XWiki 12.6.8 to XWiki 13.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              iandriuta Ilie Andriuta
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: