Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18431

"An error occurred while uploading" attachments on IE 11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 13.1
    • Fix Version/s: None
    • Component/s: Attachments
    • Labels:
    • Environment:
      Windows 10, IE 11
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce:

      1. Access instance with IE11
      2. Add any attachment to a page by clicking on Attachments > Browse > Add any kind of document (image, doc etc.)

      Expected results: The attachments are uploaded with a success message.

      Actual results: "An error occurred while uploading" message appears.

      After page refresh the attachments appears uploaded on the page.

      In the wiki console:

      2021-03-11 13:35:39.952:WARN:oejs.HttpChannel:qtp668849042-159: handleException /xwiki/bin/get/IE%2011/ java.io.IOException: Missing initial multi part boundary
      

      NOTE: This issue only reproduces on IE 11. It is working with success message on Chrome 89, Firefox 86 and Edge 89.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ganechitoaei Gabriela Anechitoaei
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Date of First Response: