Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-18439

Live Table, filter by XWiki User doesn't works

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 10.11.9, 12.10.4
    • Fix Version/s: None
    • Component/s: LiveTable
    • Labels:
      None
    • Difficulty:
      Easy
    • Similar issues:

      Description

      I have a table of class object that we called MembershipRequestClass containing a title a date and a targeted user ( that was created with an app within minutes and the User picker )

      {{velocity}}
      #set ($columnsProperties = {
       'doc.title': {"link":"view"},
       'username': {"html":true},
       'doc.date': {}
      })
      #set ($options = {
       'className': 'Collaboratory.Apps.Membership.MembershipRequest.Code.MembershipRequestClass',
       'translationPrefix': 'membershiprequest.livetable.',
       'tagCloud': true,
       'rowCount': 15,
       'maxPages': 10,
       'selectedColumn': 'doc.date',
       'defaultOrder': 'desc'
      })
      #set ($columns = ['doc.title', 'target', 'username', 'status', 'doc.date'])
      #livetable('membershiprequest' $columns $columnsProperties $options)
      {{/velocity}}
      

      It's display like this.

      But if in the filter list I choose one of the xwiki username ( the usernames provided are corrects ) I don't see any results after.

      Should be easily reproduce by just creating a class containing a user ( we use user picker ), generate some items and the table.

       

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cracky5457 Axel
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Date of First Response: