Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-19738

Macros uninstalled through EM are still displayed as installed in WYSIWYG macros picker

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 14.4-rc-1
    • Fix Version/s: None
    • Component/s: Extension, Rendering
    • Labels:
      None
    • Environment:
      Windows 11 Pro 64 bit, Chrome 101, using a local instance of XWiki 14.4 RC1 on MariaDB 10.6, Tomcat 9.0.63
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Edit a page with CKEditor
      2. Click 'Insert' > 'Other Macros'
      3. In Filter box, search for a macro that is not installed (and displayed in 'Not Installed' category), e.g. 'JW Player'
      4. Click 'Install' (verify the macro is listed as installed in the picker afterwards)
      5. Go to Administer Wiki > Extensions > Extensions and uninstall this macro
      6. Edit again the page with CKEditor
      7. Click 'Insert' > 'Other Macros'
      8. In Filter box, search for the previously uninstalled macro

      EXPECTED RESULTS

      The macro is only displayed as 'Not installed' (one entry in the list).

      ACTUAL RESULTS

      In macros picker, there are now 2 entries for JW Player macro, one which appears to be installed and one displayed as 'Not installed'.

      The issue that macros remain displayed on macros picker after uninstalled through EM reproduces on 14.3.1 and on 13.10.5 too.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            iandriuta Ilie Andriuta
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: