XWiki Platform
  1. XWiki Platform
  2. XWIKI-5524

Adding a class property that already exists succeeds without errors, although the property wasn't really added

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      1. Open a document in the class editor
      2. Add a property named "prop"; success
      3. Add a property named "prop", with a different type; apparently success, but only one of the two properties really exists, usually the first one.

      Ideally, step 3 should fail with a warning, "Property <<prop>> already exists"

      1. XWIKI-5524Patch
        2 kB
        Stefan Abageru
      1. duplicate.png
        69 kB

        Issue Links

          Activity

          Hide
          Stefan Abageru added a comment -

          Patch for this bug.

          Show
          Stefan Abageru added a comment - Patch for this bug.
          Hide
          Ecaterina Moraru (Valica) added a comment -

          Still present in 4.3

          Show
          Ecaterina Moraru (Valica) added a comment - Still present in 4.3
          Hide
          Sergiu Dumitriu added a comment -

          Fixed in 8614675

          Show
          Sergiu Dumitriu added a comment - Fixed in 8614675

            People

            • Assignee:
              Sergiu Dumitriu
              Reporter:
              Sergiu Dumitriu
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: