Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-5668

Wiki macros fail to register correctly on the first import of a .xar

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5 RC1, 2.6 RC1
    • Fix Version/s: 2.6 RC2, 2.7 RC1
    • Labels:
      None
    • Environment:
      ubuntu 10.10, tomcat 6, mysql
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Note that it will only happen for .xars which modify the guest rights (like the default enterprise .xar).

      This is reflected by the fact that spaces and tagcloud on the main page are reported as unknown when importing the default enterprise .xar (versions 2.5RC1+ and 2.6RC1+) in a fresh war.
      I tested on ubuntu 10.10, tomcat 6 and mysql db, with the following steps:

      • import war
      • restart webcontainer
      • import .xar with the default options ("Add a new version to the existing document")
      • log in
      • go to main page: "Unknown macro spaces" and "Unknown macro tagcloud" are displayed in the left column.

      Note that restarting the container fixes the issue, going to the main page displays the executed macro correctly. Also note that on subsequent imports it does not reproduce (if the .xar is reimported).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lucaa Anca Luca
                Reporter:
                lucaa Anca Luca
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: