XWiki Platform
  1. XWiki Platform
  2. XWIKI-6029

Latest modified pages don't show up in XEM path based

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.6.1
    • Fix Version/s: 3.0 RC1
    • Component/s: WYSIWYG Editor
    • Labels:
      None
    • Development Priority:
      High
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce :

      • XEM
      • Path based
      • Create or update somes pages on any sub wiki
      • Edit a page in WYSIWYG mode
      • Click on "Links" button
        => Latest modified pages do not appear.

      Tested KO with a global and local user.
      Tested OK on a domain based wiki.

        Activity

        Marius Dumitru Florea added a comment -

        The problem is that GWT-RPC services are called using URLs like this: http://<server>/xwiki/resources/js/xwiki/wysiwyg/xwe/SomeService.gwtrpc which don't include the name of the wiki in path-based XEM. In domain-based XEM the name of the wiki is included in the <server> part.

        Marius Dumitru Florea added a comment -

        Unfortunately the commit on the 2.7 branch was lost during the migration from SVN to Git so this issue is not fixed on XE 2.7.2 release.


          People

          • Assignee:
            Marius Dumitru Florea
            Reporter:
            Thibaut Camberlin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: