XWiki Platform
  1. XWiki Platform
  2. XWIKI-6537

Paste button doesn't insert text copied from Word in Internet Explorer

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.1 M1, 2.7.2, 3.0.1
    • Component/s: WYSIWYG Editor
    • Labels:
      None
    • Environment:
      Internet Explorer 8, Microsoft Word
    • Difficulty:
      Easy
    • Similar issues:

      Description

      Steps to reproduce:

      • copy text from an Word document (Microsoft's Word application must be used; you don't get the same effect when using OpenOffice)
      • click the Paste tool bar button
      • paste the text in the rich text area -> the text is correctly displayed
      • click the Insert button -> the dialog closes but the text is not inserted

        Issue Links

          Activity

          Hide
          Marius Dumitru Florea added a comment -

          It seems that the wrong namespace declaration is serialized even by the native innerHTML call. This causes some problems when the pasted text is taken from the rich text area. The solution is to remove all non-HTML elements from the pasted text before sending the HTML to the server for cleaning.

          Show
          Marius Dumitru Florea added a comment - It seems that the wrong namespace declaration is serialized even by the native innerHTML call. This causes some problems when the pasted text is taken from the rich text area. The solution is to remove all non-HTML elements from the pasted text before sending the HTML to the server for cleaning.

            People

            • Assignee:
              Marius Dumitru Florea
              Reporter:
              Marius Dumitru Florea
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: