Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-6550

Stopped cluster members is out of sync when coming back

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.6.2
    • Fix Version/s: None
    • Component/s: Observation
    • Labels:
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      We have 3 servers setup in cluster mode. The configuration has been tested ok: making one configuration on one node is taken into account on the other node. What we are noticing is that after some time, node stop being in sync: one modification on a node is not taken into acount on the other node anymore. It seems that the page is still in cache when it should have been reloaded.

      Some info about the configuration:

      • XWiki 2.6
      • jgroups-2.11.0.GA.jar
      • in xwiki.properties observation.remote.enabled = true
      • in xwiki.properties observation.remote.channels = tcp1
      • tcp.xml attached

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                tcamberlin Thibaut Camberlin
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: