Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-6823

Cannot have Panels calling protected APIs requiring Programming Rights anymore

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Similar issues:

      Description

      We used to be able to use APIs requiring PR in Panels but that's no longer working and can be considered a regression.

      The reason it's now failing is because of the dropPermission call in view templates (BTW the Panels work fine in the Admin since the Admin uses the "admin" action and not the "view" one and it seems the "admin" template doesn't have dropPermission protection).

      We need to find a solution to allow using APIs requiring PR in Panels.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                vmassol Vincent Massol
              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: