XWiki Platform
  1. XWiki Platform
  2. XWIKI-7821

Add a message for the Livetable's empty state

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      When the Livetable doesn't have any items, we should display a message stating so.

      This would be consistent with the way we handle empty states for other comments, attachments, etc. (using the .noitems class)
      Also this could be a distinctive mark that the livetable loaded fully (but it's empty). This state would differentiate from the 'still loading' state or a 'fail' state.

      1. after.png
        21 kB
      2. before.png
        19 kB
      3. context.png
        89 kB
      4. livetableEmptyMessage.png
        32 kB
      5. livetableEmptyMessage-withResults.png
        100 kB

        Activity

        Hide
        Eduard Moraru added a comment - - edited

        Implemented by displaying the results limits at the bottom of the livetable, just as it is done at the top of the livetable. (See my 2 attached screenshots)

        This goes by the initial UI proposals of the livetable pagination and it also solves the problems this issue describes.

        Show
        Eduard Moraru added a comment - - edited Implemented by displaying the results limits at the bottom of the livetable, just as it is done at the top of the livetable. (See my 2 attached screenshots) This goes by the initial UI proposals of the livetable pagination and it also solves the problems this issue describes.
        Hide
        Marius Dumitru Florea added a comment -

        Why is "per page of" text not aligned vertically with "Results out of"?

        Show
        Marius Dumitru Florea added a comment - Why is "per page of" text not aligned vertically with "Results out of"?
        Hide
        Eduard Moraru added a comment -

        Yes, I`ve noticed that as well. Seems to only happen on Firefox. Created XWIKI-10563 to track it.

        Show
        Eduard Moraru added a comment - Yes, I`ve noticed that as well. Seems to only happen on Firefox. Created XWIKI-10563 to track it.
        Hide
        Ecaterina Moraru (Valica) added a comment -

        Not working for Flamingo skin.

        Show
        Ecaterina Moraru (Valica) added a comment - Not working for Flamingo skin.
        Hide
        Eduard Moraru added a comment -

        Should be ok now. Forgot to include Flamingo's forked macros.vm.

        Show
        Eduard Moraru added a comment - Should be ok now. Forgot to include Flamingo's forked macros.vm.
        Hide
        Andreea Popescu added a comment -

        Is working ok on Flamingo (FF31/ 6.2 M1)

        Show
        Andreea Popescu added a comment - Is working ok on Flamingo (FF31/ 6.2 M1)
        Hide
        Guillaume Delhumeau added a comment -

        I don't see it in the current snapshot.

        Show
        Guillaume Delhumeau added a comment - I don't see it in the current snapshot.
        Hide
        Marius Dumitru Florea added a comment -

        Guillaume Delhumeau I can see it.

        Show
        Marius Dumitru Florea added a comment - Guillaume Delhumeau I can see it.

          People

          • Assignee:
            Eduard Moraru
            Reporter:
            Ecaterina Moraru (Valica)
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: