Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-7885

Message Stream input is not displayed when editing the Dashboard

    Details

    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Because of validation and layout issues the Message Stream functionality was removed in the inline mode (see XE-856 ).

      The problem is that in 4.1 RC1 (see XWIKI-7875 ) we have now 2 different gadgets in the Dashboard and one of them is empty.

      Because the Dashboard mimics in inline mode the display of the view mode, the 'Send Message' macro should mimic also the way the input looks, even if it doesn't offer the functionality.

      The previous display problem with the message stream was that the "form" declaration was lost and this way it was losing also the styling classes: "messagestream activityUser xform".

      A solution would be to have another container hold these classes.
      Also in order to show that the functionality is disabled, the form input should add disabled states: "disabled='disabled'"

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                enygma Eduard Moraru
                Reporter:
                evalica Ecaterina Moraru (Valica)
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: