Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-7944

Issue with upgrading a XAR application with a conflict

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 4.1
    • Fix Version/s: None
    • Component/s: Extension
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      I've done the following test in a 4.1 installation:

      1/ Create an extension with a test page with a certain content by exporting a single page (with no history)
      2/ Install that extension in a wiki
      3/ Modify the page locally in the wiki
      3/ Publish a new version of that extension by exporting a modified version of the page (with a conflicting modification of the same line)
      4/ Upgrade that extension

      The version is not upgraded but there is no error message. Finally I cannot install anything anymore as EM seems broken.

      The following stacktrace overflow is seen:

      at org.xwiki.logging.LogQueue.error(LogQueue.java:414)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                ludovic Ludovic Dubost
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: