XWiki Platform
  1. XWiki Platform
  2. XWIKI-8394

Workspace owner and initial members not set as members (nor in admin group) when the workspace identifier contains an underscore

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.5.1
    • Fix Version/s: 4.5-rc-1
    • Component/s: {Unused} Workspaces
    • Labels:
      None
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Normally, the user which is the owner of the created workspace is added in the local XWikiAllGroup (workspace members) and explicitly in the local XWikiAdminGroup (local admins) and the initial members are added in the local XWikiAllGroup.
      If the workspace name contains an underscore though, like "my_workspace" for example, this is not happening, the all group is empty and so is the admin group.

      An immediate result of this is that when the owner of the workspace is accessing the workspace, the workspace information panel asks him to join the workspace since he doesn't find him as member and the initial members are not set. Other side effects might be possible.

      To reproduce: create a new workspace using the link in the main home, choose some initial members (different from the owner), membership type doesn't matter but I tried with "Open". In the newly created wiki, go in administration in groups and all groups will be empty.

        Activity

        Anca Luca added a comment - - edited

        The issue is caused by the fact that workspace manager is trying to use the workspace identifier as the wiki name when, in fact, the wiki name will be the workspace name without the underscores.

        Indeed this can be misleading, since the subwiki thus created will not have the name that the user thinks it will have (the workspace identifier), but this should be handled as a different issue. Putting users properly in groups can be done even if the workspace identifier is different than the wiki name.


          People

          • Assignee:
            Eduard Moraru
            Reporter:
            Anca Luca
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: