Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-8507

Wrong URL used for "Install" and "Details" buttons on "Add Extensions" admin page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.3-rc-1
    • Fix Version/s: None
    • Component/s: Extension
    • Labels:
    • Environment:
      Ubuntu 12.04 64 bit, nginx, tomcat7, openjdk 1.7, mysql
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      When I setup xwiki on tomcat running on localhost:8080 and nginx in front of it rewriting and proxying everything down to https to tomcat I get a error when clicking on the buttons mentioned in the Summary.

      What happens is that it uses http instead of https which causes nginx to redirect it to https and then it fails.

      in xwiki.cfg I have:
      xwiki.url.protocol=https

      my nginx /etc/nginx/sites-enabled/default config
      http://paste.ubuntu.com/1389016/

      I tried with the help of cjd to debug it but was asked to report this bug.

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              ekarlso Endre Karlson
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: