Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-8580

UI misleading on Workspace installation or upgrade if the database already exists

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 4.3
    • Fix Version/s: None
    • Component/s: {Unused} Workspaces
    • Labels:
      None
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      • setup a XEM using MySQL
      • make sure you already have the workspacetemplate database created. (Yes, this will result in a stacktrace)
      • Install the XEM using Distro Wizard or by manually importing the XAR
      • On the Workspace install page, the user will not see any stacktrace nor any failure about this. The user needs to look at the stacktrace from the console.

      I don't know if the database is overwritten resulting in a successful install, but user will always get a warning that Workspaces are not installed, but when he goes to the Workspace.Install page, he has no button to retry the installation.

      IMO this is very fragile for end users and I personally don't know any workaround or how to trigger another installation attempt of Workspaces.

      Images attached

        Attachments

          Activity

            People

            • Assignee:
              gdelhumeau Guillaume Delhumeau
              Reporter:
              sorinello Sorin Burjan
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: