Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-8927

Language cookie is not updated with the Default Language set in XWiki Preferences

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 5.0-milestone-1, 4.5.2
    • Fix Version/s: None
    • Component/s: Old Core
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      When setting up let's say a french language XWiki, I go to the XWiki Preferences and set

      MutilLingual : Yes
      Languages : fr
      Default Language : fr

      • clear cookies
      • access your wiki
      • click to login
      • when redirected to the login page, the language is automatically set to en in the cookie
      • login
      • language is still en in the language cookie
      • Main.WebHome has translations for french, but the cookie is still set automatically to en

      To set the cookie to fr, I have to click on the default button or appent "?language=fr" in order to change my cookie language to fr.

      Reported this as a bug because it is very confusing for the end user, which is expecting for the wiki to be in french even before the login page, or without having to press any additional buttons.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sorinello Sorin Burjan
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Date of First Response: