Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-9354

require(['jquery'] pollutes the global namespace breaking prototype

    Details

    • Difficulty:
      Unknown
    • Documentation:
      n/a
    • Documentation in Release Notes:
      n/a
    • Similar issues:

      Description

      Since the update of jQuery in 006968b921, it now overrides window.$ which breaks prototype when it is pulled in using require(['jquery']...).

        Attachments

          Activity

            People

            • Assignee:
              calebjamesdelisle CalebJamesDeLisle
              Reporter:
              calebjamesdelisle CalebJamesDeLisle
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: