XWiki Platform
  1. XWiki Platform
  2. XWIKI-9457

Confusing information in Installed Extensions after migrating from 4.5.4 to 5.2M2

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.2-milestone-2
    • Fix Version/s: None
    • Component/s: Extension
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      • Create a 4.5.4 XEM using DW, install Workspaces, and create 2 Workspaces
      • Upgrade the wiki to 5.2M2 using DW
      • At step 3, select upgrade all wikis

      After finishing, go to Main wiki and go to Extensions Manager.

      From a user POV, I am unable to understand several things there, which might be confusing for the end-user. Some of them are listed, even if they have an installed button. Others seem to have version 5.1 instead of 5.2M2. This is very confusing for the end-user.

      Images attached.

      1. EXtensions1.png
        52 kB
      2. EXtensions2.png
        57 kB
      3. Extensions3.png
        15 kB
      4. To53.png
        31 kB

        Activity

        Thomas Mortagne added a comment - - edited

        1) listed in which wiki(s) ?
        2) EM does not uninstall dependencies (Application Manager Aplication) when an extension is uninstalled (XEM) and nothing replace "Application Manager Aplication" in 5.3 so yes it's normal

        Sorin Burjan added a comment -

        It appears like this only in the main wiki (with the Install button). The application is listed as installed on the subwikis also, but not with an "Install" button. On subwikis it appears with the "Uninstall" button, which is normal.

        Thomas Mortagne added a comment -

        Ok so you see it on the main wiki because you see all installed extensions on the main wiki and you can install it because it's not installed on the main wiki so it's all normal. XWIKI-9824 makes it a bit unclear that's it's actually installed somewhere.

        Vincent Massol added a comment -

        From IRC:

        sburjan: click show details, it should list on which wikis it's installed
        it's normal that it's not installed in the main wiki
        it's an extension for subwikis
        so it's normal you get an install button for the main wiki

        Thomas Mortagne added a comment -

        Closing since we cannot reproduce anymore, fixed in other issues.


          People

          • Assignee:
            Sorin Burjan
            Reporter:
            Sorin Burjan
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: