XWiki Platform
  1. XWiki Platform
  2. XWIKI-9458

Badly merged title field when migrating from XEM 4.5.4 to XE 5.2M2

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.2-milestone-2
    • Fix Version/s: None
    • Component/s: Extension
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      • create a wiki (Manager) on 4.5.4
      • migrate it using DW to 5.2M2
      • during the migration you will receive a merge conflict in Main.WebHome
      • after DW finishes, the title of the page is no properly rendered because the key does not exist.

      Note that I left the default/selected option when I hit the continue button to fix the merge conflict

      Images attached

        Activity

        Vincent Massol added a comment -

        I see in our sources that we have:

        <title>$services.localization.render('manager.homepage.title')</title>
        

        The merge look strange if it results in "xer.homepage.title"... No idea why. What merge option did you choose sorin?

        Sorin Burjan added a comment -

        As I stated in the description of the issue, "Note that I left the default/selected option when I hit the continue button to fix the merge conflict" .. and as the screenshot says, the option is "Keep the merged version"

        Marius Dumitru Florea added a comment -

        Looks like the merge between:

        $msg.get('manager.homepage.title')
        

        (as current version) and

        $services.localization.render('xe.homepage.title')
        

        (as next version) produced

        $services.localization.render('xer.homepage.title')
        

        The only missing information in order to reproduce this in an unit test is the original (previous) version that was used in the 3-way merge.

        Thomas Mortagne added a comment -

        Yes when you have things like this the best is to look at all comparisons. A merge always means that there is 3 different versions, if you did not touched anything before upgrading that itself sounds like something to debug. I would bet for EM using XE previous XAR instead of the XEM one (and so something like $msg.get('xe.homepage.title') instead of $msg.get('manager.homepage.title')) for some reason.

        Sorin Burjan added a comment -

        I did not touched anything, so I'm sure it's not a user fault here.

        Sorin Burjan added a comment -

        I am unable to reproduce it anymore when migrating from 4.5.4 to 5.3. I have selected upgrade all wikis option, and I migrated the tempate and the 2 workspaces created. None of them gave conflict on Main.WebHome. This issue can now be considered invalid on 5.3.

        Thomas Mortagne added a comment -

        Cannot reproduce anymore. Fixed in other issues.


          People

          • Assignee:
            Sorin Burjan
            Reporter:
            Sorin Burjan
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: