XWiki Platform
  1. XWiki Platform
  2. XWIKI-9468

Distribution Wizard version picker during XE upgrade list only versions =< 4.2

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2-milestone-2
    • Fix Version/s: 5.4-rc-1
    • Component/s: Extension
    • Labels:
    • Development Priority:
      High
    • Difficulty:
      Medium
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      To reproduce:
      Have a instance running another version of XWiki. Install 5.2-milestone2 and at the first run, in Distribution Wizard, it won't be able to guess the version you're running (it seems to be another issue spotted by LM), so click on the button to pick your own version, and in the next panel, you'll have a list of XWiki versions, but it goes until 4.2, not beyond.

        Issue Links

          Activity

          Marius Dumitru Florea added a comment -

          I fixed it by retrieving the list of available versions dynamically. Note that I'm listing only the stable versions (no milestones and no release candidates), otherwise the version select is too crowded for simple users.


            People

            • Assignee:
              Marius Dumitru Florea
              Reporter:
              Guillaume Fenollar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: