Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-9673

Main wiki descriptor page XWiki.XWikiServerXwiki is missing after Wiki Manager installation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 5.2
    • Fix Version/s: 5.4-milestone-1
    • Component/s: Wiki
    • Labels:
      None
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      The problem with Main Wiki descriptor has very interesting behaviour.

      #xwiki.virtual.failOnWikiDoesNotExist=1

      in xwiki.cfg gives following:

      • XWiki runs with IP based URL fine
      • XWiki gives "wiki does not exist" on domain based URL

      Creation Wiki.XWikiServerXwiki page + adding object of XWiki.XWikiServerClass to it solves the problem if alias is set up.
      Main Wiki started to run on domain based URLs correctly.

      The proposal is to bundle Wiki.XWikiServerXwiki page by default with XE (or Wiki manager) not to confuse users.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gdelhumeau Guillaume Delhumeau
                Reporter:
                haru Dmitry Bakbardin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: