XWiki Platform
  1. XWiki Platform
  2. XWIKI-9808

When renaming an extension with xwiki.extension.feature, the UI does not present the new version as an upgrade

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.1
    • Fix Version/s: 5.4-rc-1
    • Component/s: Extension
    • Labels:
    • Development Priority:
      High
    • Difficulty:
      Medium
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      How to reproduce (inspired from the life of extension http://extensions.xwiki.org/xwiki/bin/view/Extension/Meeting+Application ):

      • Make an extension with an id, say, tdelafosse:meeting-application
      • release one version, say 1.2, install it on a wiki using extension manager
      • Change the id of the extension, declaring it as an alias of the old extension in the pom as follows:
          <properties>
            <xwiki.extension.features>tdelafosse:meeting-application</xwiki.extension.features>
          </properties>
        
      • release version 1.2.1, publish the new version
      • go to the wiki where the extension is installed in administration, you will see the following situation:
        • in installed extensions, you will see meeting application with version 1.2 as installed. UI will not propose upgrade.
        • in all extensions, you will find the meeting application with version 1.2.1. UI will not present it as an upgrade of the existing extension
      • however, when clicking on "install" for the new extension, upgrade will be written in the install plan and upgrade will be performed when continuing to install

      I would expect that the UI notifies that there is a new version for the extension when I look at installed extensions, that it would behave exactly in the same way as when a new version of an extension is available.

        Activity

        Thomas Mortagne added a comment -

        in installed extensions, you will see meeting application with version 1.2 as installed. UI will not propose upgrade.

        You are mixing 2 different things, this one is not a bug. There is no such support in Extension Manager. The only bug here is that you get "INSTALL" button instead of "UPGRADE" one.

        Marius Dumitru Florea added a comment -

        The only bug here is that you get "INSTALL" button instead of "UPGRADE" one.

        Thomas is referring of course to the "All Extensions" view. For the notification part, there is already XWIKI-8321.

        Anca Luca added a comment -

        First of all, to clearify, by "UI propose upgrade" I actually mean "ui shows an upgrade button". No notification, no automatic checking of whatever.

        So I read the comments and related issue and an issue related to the related issue and I understand that:

        Please confirm this understanding.

        Thomas Mortagne added a comment -

        Please confirm this understanding.

        I confirm


          People

          • Assignee:
            Marius Dumitru Florea
            Reporter:
            Anca Luca
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: