Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-12746

openTo parameter doesn't work when root parameter is specified and has the default value

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.3-milestone-2
    • Fix Version/s: 7.3-rc-1
    • Component/s: Index
    • Labels:
      None
    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      ... if the node to open to is not on the first page of top level nodes.

      You can reproduce like this:

      {{documentTree openTo="document:xwiki:Main.Welcome" root="wiki:xwiki" /}}
      
      • wiki:xwiki is the default root and is specified
      • Main.Welcome is not a top level page

        Attachments

          Activity

            People

            • Assignee:
              mflorea Marius Dumitru Florea
              Reporter:
              mflorea Marius Dumitru Florea
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - Not Specified
                Not Specified
                Logged:
                Time Spent - 2 hours
                2h