XWiki Platform
  1. XWiki Platform
  2. XWIKI-13256

Viewing a PPT / ODP with the Office Macro fails when on a nested page

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 7.4
    • Fix Version/s: 8.3, 8.2.2, 7.4.6
    • Component/s: Office
    • Labels:
    • Environment:
      OpenOffice 3.2
    • Tests:
      Unit
    • Development Priority:
      High
    • Difficulty:
      Medium
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      • XE 7.4 with OO server running
      • Create a new page
      • Create a sub-page of that page (non-terminal)
      • Import a PPT / ODP file
      • The references to images are not working

        Issue Links

          Activity

          Marius Dumitru Florea added a comment -

          Guillaume Lerouge can you tell us what is the generated wiki syntax for the imported office presentation?

          Guillaume Lerouge added a comment - - edited

          Attached the file I used for testing as well as the resulting syntax.

          The macro call is:

          {{office attachment="Company Presentation.ppt"/}}
          Marius Dumitru Florea added a comment -

          We need to check if temp action supports nested spaces. Vincent Massol is assigned to XWIKI-10375 but this is older than nested spaces.

          Vincent Massol added a comment - - edited

          FTR I've tried importing the attached PPT into a nested page (E.F.Office.WebHome) and it worked well.

          The issue is with the office macro's getTemporaryFile() method which doesn't take into account nested spaces while the generated URLs do take them into account + the struts TempAction not supporting nested spaces.

          Vincent Massol added a comment -

          So in short, I believe making the TempAction support Nested spaces is about the same cost of implementing XWIKI-10375. It would be possible to support Nested Spaces in the TempAction by concatenating all spaces together into a single space string but that would not scale when you have large hierarchies on Windows (max 260 - 12, see https://msdn.microsoft.com/en-us/library/windows/desktop/aa365247(v=vs.85).aspx ).


            People

            • Assignee:
              Marius Dumitru Florea
              Reporter:
              Guillaume Lerouge
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: