Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14070

UIX still present after page removed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 8.4.4
    • Fix Version/s: None
    • Component/s: UI Extension
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Happened on playground.xwiki.org with version 8.4.4.

      Steps:

      • I've created an AWM application with a new normal local user;
      • AWM registers UIX for point 'org.xwiki.platform.panels.Applications' with the scope 'Current User'
      • Overnight the playground gets reset. This means that the users get deleted and also the pages created by the users
      • Next day I've recreated the user and logged in: the AppBar display the UIX for the 'TEst' app, but the pages are deleted so the UIX definition is not present.

      This is not a synchronization issue (XWIKI-14069) since the UIX is displayed on both playground nodes, see:

      • Node1:
      • Node2:

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                evalica Ecaterina Moraru (Valica)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: