Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14166

Inline edit not saving documents with default language blank and existing translation in the configured default language

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Solved By
    • Affects Version/s: 8.4.4, 11.2
    • Fix Version/s: None
    • Component/s: Old Core
    • Labels:
      None
    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      1. Set the wiki multilingual, with default language en and available languages en,fr
      2. Go to http://localhost:8080/xwiki/bin/edit/Panels/Navigation and replace the content with test (Save&View)
      3. Go to http://localhost:8080/xwiki/bin/edit/Panels/Navigation?language=en (edit mode, but specify the language=en) and replace test with my change (Save&View)
      4. Notice the change has not been saved (in view mode)
        1. Go back to either http://localhost:8080/xwiki/bin/edit/Panels/Navigation?language=en or http://localhost:8080/xwiki/bin/edit/Panels/Navigation?language= and see that the change has not been saved anywhere.

      *Workaround*:
      Delete the english translation (go in wiki edit mode on the translation and then hit delete page) to fix the document and leave it only with the no-language, original translation.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                surli Simon Urli
                Reporter:
                enygma Eduard Moraru
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: