Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14165

Unable to edit the original document if it has default language blank and en (configured default translation) translation exists

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 8.4.4, 11.2
    • Fix Version/s: 11.3-rc-1
    • Component/s: Old Core
    • Labels:
      None
    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Pull Request Status:
      Pull Request accepted
    • Similar issues:

      Description

      Steps to reproduce:

      1. Set the wiki multilingual, with default language en and available languages en,fr
      2. Create a new page and set its default language to blank (advanced user, wiki edit mode).
        1. Set the content to Original content.
      3. Create an en translation of that document.
        1. Set the content to English content.
      4. Try to go back to the original document in edit mode (press the "default" link in the existing translations section).
      5. You will always be editing the en translation and are not able to go back to the original document.

      Workaround:
      Go to the english translation and hit delete page, in order to delete the english translation. This will leave the original document editable.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                surli Simon Urli
                Reporter:
                enygma Eduard Moraru
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: