Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.4-rc-1
    • Fix Version/s: None
    • Component/s: Dependency Upgrades
    • Labels:
      None
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      0.26:

      CSS4J CHANGES
      =============

      Version 0.26
      ------------

      • Core:
      • Add the convenience method setDefaultHTMLUserAgentSheet() to
        CSSStyleSheetFactory.
      • Simplified one of the methods in SheetErrorHandler.
      • Added a toString() method that returns getCssText() in
        BaseCSSStyleDeclaration.
      • Remove deprecated methods from StyleDatabase.
      • Fixed a possible class cast problem in style declaration.
      • Unit conversions simplified, and values no longer need StyleDatabaseAware.
      • New tests for wrapper-based computed styles.
      • Small fix for DOMCSSStyleSheetFactoryTest.
      • Fixed a regression in setting the border-width shorthand when the value is
        zero.
      • Apply constrains to border-width computed vaues.
      • Added getComplianceMode() to CSSStyleSheetFactory.
      • Add support for the 'initial' keyword.
      • Remove StyleDatabaseAware interface.
      • StyleDatabase: getWidthSize(widthIdentifier, fontSize) replaces
        getWidthSize(widthIdentifier), which is deprecated. Also, method
        stringWidth(text, style) added to CSSCanvas.
      • Added support for 'ex' units in getComputedFontSize().
      • Small documentation change for StyleDatabase.
      • Additional tests for border properties.
      • Dom4j module:
      • Fixed a possible class cast problem in style declaration.
      • Implemented setDefaultHTMLUserAgentSheet in XHTMLDocumentFactory.
      • Set TestDocumentFactory compliance mode to quirks.
      • Add a convenience method to XHTMLDocumentFactoryTest.
      • Remove mention to StyleDatabaseAware interface.

      0.25:

      CSS4J CHANGES
      =============

      Version 0.25
      ------------

      • The library has been modularized: there is the css4j core, and the dom4j,
        visual and java2d modules. Most users will just want the 'css4j' and
        'css4j-dom4j' jar files. The 'java2d' module depends on 'visual'.
      • The style sheet factories can now operate under a compliance mode. Two modes
        are currently supported: LENIENT and QUIRKS. LENIENT is intended for the case
        where no style database is available, and it allows to compute values by
        giving reasonable defaults to properties with system-dependent initial values:
        '#ffffff' for color and 'serif' for font-family. It is recommended to provide
        a style database and work with the QUIRKS mode, however. Stand-alone style
        declarations always work in QUIRKS mode. A STRICT mode may be available in the
        future.
      • Now all CSS3 color identifiers can be used for any color property in any
        shorthand. And identifier values that contain a valid color identifier deliver
        a proper RGBColor when getRGBColorValue() is called.
      • StylableDocumentWrapper and DOMCSSStyleSheetFactory were moved from package
        doc.style.css to doc.style.css.dom.
      • More consistent handling of property name case at getPropertyValue and
        getPropertyCSSValue.
      • Improved upper/lower case tolerance for dom4j elements. Now elements with an
        uppercase 'ID' attribute should work as if the 'id' was lowercase.
      • Removed logging from a few places where it was unnecessary.
      • DOM wrapper cascade fix.
      • Fix for readURL in the wrapper-based user agent of DOMCSSStyleSheetFactory.
      • Fixed a bug matching the lang attribute in selectors.

        Issue Links

          Activity

          Vincent Massol added a comment -

          To deploy in our externals maven repo:

          mvn deploy:deploy-file -Durl=http://nexus.xwiki.org/nexus/content/repositories/externals -DrepositoryId=nexus.xwiki.org -Dfile=pom.xml -DpomFile=pom.xml 
          mvn deploy:deploy-file -Durl=http://nexus.xwiki.org/nexus/content/repositories/externals -DrepositoryId=nexus.xwiki.org -Dfile=css4j-0.26.jar -DpomFile=css4j/pom.xml 
          mvn deploy:deploy-file -Durl=http://nexus.xwiki.org/nexus/content/repositories/externals -DrepositoryId=nexus.xwiki.org -Dfile=css4j-dom4j-0.26.jar -DpomFile=css4j-dom4j/pom.xml 
          
          Vincent Massol added a comment -

          Overridden by XWIKI-14346 which I created, forgetting that this issue was closed for 9.5RC1 too.


            People

            • Assignee:
              Vincent Massol
              Reporter:
              Vincent Massol
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: