Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15388

Menus don't appear in the Left/Right panels anymore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 10.5-rc-1, 10.5, 9.11.6
    • Fix Version/s: 9.11.7, 10.6-rc-1
    • Component/s: Menu
    • Labels:
    • Environment:
      Windows 10, Edge 17, Chrome 67
    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Steps to reproduce:

      1. Log in as Admin
      2. Click on Menu
      3. Click on Add New Entry
      4. Insert an entry name
      5. Choose at the menu display location: Inside a left/right panel
      6. Choose at the menu visibility: Current Wiki
      7. Save the page
      8. Go to Administration > Look & Feel > Panels > PANELS DISPLAYED ON THE LEFT / RIGHT and add Menu.Name (without spaces between panel components and separated by comma)
      9. Save the configuration
      10. Refresh the page

      Expected results: The Menu is visible for the current wiki inside the left/right Panels.

      Actual results: The menu doesn't appear in the left or right panel.

      NOTE: I think the issue is because of XWIKI-15387 - I've tried with Menu.New2 and Menu.WebHome in administration but nothing works.

      Note: Working on 10.4

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                ganechitoaei Gabriela Anechitoaei
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: